2017年11月8日 星期三

臺灣 固定ip 有些網站很慢

/ip firewall mangle
add action=change-mss chain=forward comment="\B3\CC\AB\E1\A4@\B1\F8\A6\B3mangle\AA\BA\B3\
    \A1\A4\C0\ACO\A6]\AC\B0PPPOE\BC\B7\B8\B9\A5X\A5h\AA\BA\AB\CA\A5]\A4j\A4p\A5i\AF\E0\A5[\
    \A4WPPP HEADER\B7|\B6W\B9L1500BYTE\A1A\A6]\A6\B9\A5\B2\B6\B7\ADn\B3B\B2z\C1Y\A4p\A1A\
    \B3o\C3\E4\B4N\A5\D1\A8t\B2\CE\A6\DB\A6\E6\A7P\C2_\C1Y\A4p\AA\BA\B5{\AB\D7(clamp-to-pm\
    tu)" new-mss=clamp-to-pmtu passthrough=no protocol=tcp tcp-flags=syn




修改出口封包大小


ex
最後一條有mangle的部分是因為PPPOE撥號出去的封包大小可能加上PPP HEADER會超過1500BYTE,因此必須要處理縮小,這邊就由系統自行判斷縮小的程度(clamp-to-pmtu)

2017年11月6日 星期一

routeros wifi 連線



wifi 連線部份 參考




http://www.irouteros.com/news.php?id=56 



主要 site  設定為  ab bridge

country   israel

manual-txpower




Frequency 設定  auto






另一邊


設定
station wds


20/40MHz eC

2472


Manual-txpower

israel











2017年1月24日 星期二

smartdns 不穩定運作

window 10 因  ipv6 .
不穩定

cmd
ipconfig /all

Teredo Tunneling Pseudo-Interface


https://lonesysadmin.net/2011/04/25/how-to-disable-teredo-ipv6-tunneling-in-microsoft-windows/


netsh interface teredo set state disabled
routeros ipv6 關閉 也無法解決,

2016年12月6日 星期二

ipconflg /all 還有 ipv6 該如何移

跟移不掉的幽靈網卡說掰掰!

如果你的網路常常出現「IP位址衝突」的訊息,但明明自己的IP並 沒有和別人相同,這可能是你之前安裝過其它網卡所搞的鬼 。或者你將網路卡換過插槽,會造成原先插槽對應的驅動程式沒有真正 被卸除,此時都可能佔據住原本的IP而與另一張網卡相衝 。這邊就要教你如何真正卸除掉殘留的網卡驅動程式。


STEP

1. 首先按下【開始】→【執行】,在對話框中輸入「cmd 」來叫出命令提示字元視窗。

2. 輸入「set devmgr_show_nonpresent_devices=1」並按下〔Enter〕,此命令是用來讓裝置管理員中的隱藏裝 置顯示出來。

3. 接著繼續輸入「start devmgmt.msc」,呼叫出「裝置管理員」視窗。

※如果沒有從這裡下指令呼叫,而是直接從控制台開啟「裝置管理員 」,那麼某些隱藏的硬體裝置將不會顯示出來,因此記得一定要接著輸 入上述指令喔!

4. 在「裝置管理員」視窗中,確認【檢視】→【顯示隱藏裝置 】的選項有勾選起來,這樣才能把隱藏裝置都叫出來。

5. 這時展開「網路介面卡」的清單,把 Teredo Tunneling Pseudo-Interface 及 ISATAP 網路裝置刪除


 Teredo Tunneling Pseudo-Interface 
會有  ipv6 
有設定  smart dns 要移掉這個

x86 routeros nad hAP

 rb952Ui GS-5hact2hnt



設定 CPE

Configuration 設定 Bridge

IP Address 設定內網一個 ip

其他設定內網的 GW and DNS

即可運作 成橋接 mode

DHCP Server 也是從 前端 x86 派送

interface wlan1/wlan2

設定  ap bridge mode

channel width

設定 20/40/80Mhz Ceee 不要設定 非大小開頭(印象中是主副頻道,選 邏輯上
干擾比較少的頻道)

2016年7月18日 星期一

GoogleMonkeyR 1.7.3.1

// ==UserScript==
// @author mungushume
// @version 1.7.3.1
// @name GoogleMonkeyR

第681行


if(this.numColumns>1)
{
style += ("#cnt.singleton #center_col, #cnt.singleton #foot, .mw {margin-left:0 !important;}");
}



增修改





if(this.numColumns>1)
{
style += ("#cnt.singleton #center_col#cnt.singleton #foot, .mw {margin-left:0 !important;}");
}
style += ("div.col {width: 100% !important;}");




info
https://greasyfork.org/en/forum/discussion/10487/googlemonkeyr-broken-again#latest

2016年7月2日 星期六

讓routeros 具有adblock 功能





# create script to Download fresh list and replace old one
/system script add name="Download_Ads_List" source="/tool fetch url=\"https://blocklister.gefoo.org/ads" dst-path=ads.rsc; /import file-name=ads.rsc;"

# create schedule to run script weekly
/system scheduler add comment="Download_Ads_List" interval=7d name="DownloadAdsList" on-event=Download_Ads_List start-date=jan/01/1970 start-time=02:42:00

# add firewall rule once
/ip firewall filter add chain=forward in-interface=bridge-local connection-state=new protocol=tcp dst-address-list=ads_list action=reject reject-with=tcp-reset comment="Ad-block list drop"

info

https://www.reddit.com/r/mikrotik/comments/3jf830/selfupdating_adblocker_script/

https://blocklister.gefoo.org/









組合技


最重要是紅色   get block lister .

/system script
add name=script1 owner=admin policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon sourc
    \_firewall filter\r\
    \nadd action=drop chain=input comment=\"\\A2b\\A2c\\A2d\\A2e\\A2f\\A2g
    1 \\A2h\\A2g\\A2f\\A2e\\A2d\\A2c\\A2b\" disabled=no dst-port=21,22,23,
    rotocol=tcp src-address-list=login_error_ip\r\
    \nadd action=add-src-to-address-list address-list=login_error_ip addre
    t-timeout=1d chain=input comment=\"\\A2b\\A2c\\A2d\\A2e\\A2f\\A2g\\A2h
    2h\\A2g\\A2f\\A2e\\A2d\\A2c\\A2b\" connection-state=new disabled=no ds
    =21,22,23,8291 protocol=tcp \\\r\
    \n    src-address-list=ros_service_login5\r\
    \nadd action=add-src-to-address-list address-list=ros_service_login5 a
    -list-timeout=1d30s chain=input comment=\"\\A2b\\A2c\\A2d\\A2e\\A2f\\A
    h 3 \\A2h\\A2g\\A2f\\A2e\\A2d\\A2c\\A2b\" connection-state=new disable
    st-port=21,22,23,8291 \\\r\
    \n    protocol=tcp src-address-list=ros_service_login4\r\
    \nadd action=add-src-to-address-list address-list=ros_service_login4 a
    -list-timeout=30s chain=input comment=\"\\A2b\\A2c\\A2d\\A2e\\A2f\\A2g
    4 \\A2h\\A2g\\A2f\\A2e\\A2d\\A2c\\A2b\" connection-state=new disabled=
    -port=21,22,23,8291 protocol=\\\r\
    \n    tcp src-address-list=ros_service_login3\r\
    \nadd action=add-src-to-address-list address-list=ros_service_login3 a
    -list-timeout=30s chain=input comment=\"\\A2b\\A2c\\A2d\\A2e\\A2f\\A2g
    5 \\A2h\\A2g\\A2f\\A2e\\A2d\\A2c\\A2b\" connection-state=new disabled=
    -port=21,22,23,8291 protocol=\\\r\
    \n    tcp src-address-list=ros_service_login2\r\
    \nadd action=add-src-to-address-list address-list=ros_service_login2 a
    -list-timeout=30s chain=input comment=\"\\A2b\\A2c\\A2d\\A2e\\A2f\\A2g
    6 \\A2h\\A2g\\A2f\\A2e\\A2d\\A2c\\A2b\" connection-state=new disabled=
    -port=21,22,23,8291 protocol=\\\r\
    \n    tcp src-address-list=ros_service_login1\r\
    \nadd action=add-src-to-address-list address-list=ros_service_login1 a
    -list-timeout=30s chain=input comment=\"\\A2b\\A2c\\A2d\\A2e\\A2f\\A2g
    7 \\A2h\\A2g\\A2f\\A2e\\A2d\\A2c\\A2b\" connection-state=new disabled=
    -port=21,22,23,8291 protocol=\\\r\
    \n    tcp src-address-list=!Lan_ip\r\
    \n\r\
    \n/ip firewall address-list\r\
    \nadd address=172.16.0.0/12 disabled=no list=Lan_ip\r\
    \nadd address=192.168.0.0/16 disabled=no list=Lan_ip\r\
    \nadd address=10.0.0.0/8 disabled=no list=Lan_ip"
add name=Blocklister_download_Ads owner=admin policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon sourc
    ol fetch url=\"https://blocklister.gefoo.org/ads\" dst-path=\"ads.rsc\
    ort file-name=\"ads.rsc\";




另一個

增加時間 自動更新

/system scheduler
add comment=Download_Ads_List interval=1w name=Blocklister_download_Ads \
    on-event=Blocklister_download_Ads policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \

    start-date=jan/01/1970 start-time=02:42:00



必須配合
ip
Filter Roules
設定 使用 AD-BLOCK 只有抓下來 沒有用 就是沒用

add action=reject chain=forward comment="Ad-block list drop" connection-state=\
    new dst-address-list=ads_list in-interface=bridge log=yes protocol=tcp \

    reject-with=tcp-reset